User Tools

Site Tools


Change Log

Below is a “sanitized” version of the Daz Studio v4.x change log. This information is posted as part of a conscious effort to be more transparent in the development process. Not all information relating to a particular build is presented on this page - some information is still considered private and is therefore not included.



General Release Channel

Public Build Channel

This is the channel where the builds that are not considered “production ready” yet are provided for testing by the general public. This channel typically provides a build that is in the BETA phase of development, but technically can provide a build in the ALPHA phase.

Public Beta (4.12.2.6)

  • Source maintenance

DAZ Studio : Incremented build number to 4.12.2.1


  • Source maintenance
  • Merged changes to Trunk (4.12.1.118)

DAZ Studio : Incremented build number to 4.12.2.2


  • Source maintenance
  • Build system tweaks

DAZ Studio : Incremented build number to 4.12.2.3


  • Source maintenance
  • Merged changes to Trunk (4.12.1.118)

DAZ Studio : Incremented build number to 4.12.2.4


  • Source maintenance
  • Merged changes to Trunk (4.12.1.118)

DAZ Studio : Incremented build number to 4.12.2.5


  • Source maintenance
  • Merged changes to Trunk (4.12.1.118)

DAZ Studio : Incremented build number to 4.12.2.6



Private Build Channel

This channel is similar to the Public Build channel, except that it is limited to a select group of individuals that serve as the “front line” or the “canary in a coal mine” for a time before the build is promoted to a less restricted channel. This channel is more likely to see an ALPHA build than the Public Build channel is.


  • Source maintenance
  • Update to dForce 1.2.2.1
    • Updates plugin revision to reflect SDK revision
    • Fixes an issue that prevented access to Publishing Partner functionality

DAZ Studio : Incremented build number to 4.12.2.7


  • Source maintenance
  • Made efficacy improvements to aniMate2/Lite
  • Fixed an issue in aniMate2/Lite that could cause nested loading of scene data to consume more time than is necessary because it would prematurely begin processing the scene as if the loading process were complete and a nested load of scene data had not yet completed
  • Fixed a potential crash in animate2/Lite when a node was added to the scene

DAZ Studio : Incremented build number to 4.12.2.8


  • Source maintenance
  • Update to NVIDIA Iray RTX 2020.0.2 (327300.6313)

DAZ Studio : Incremented build number to 4.12.2.9


  • Source maintenance
  • Extended logging of application starting/closing processes
    • Additional information to help identify/isolate which parts of starting/closing the application are having the greatest impact on a given user's configuration

DAZ Studio : Incremented build number to 4.12.2.10


  • Source maintenance
  • Build system tweaks
  • Made tweaks to DzAuxViewportPane layout

DAZ Studio : Incremented build number to 4.12.2.11


  • Source maintenance
  • Update to Filament 1.7.0.3

DAZ Studio : Incremented build number to 4.12.2.12


  • Source maintenance
  • Fixed dynamic subdivision update in PBR DrawStyle

DAZ Studio : Incremented build number to 4.12.2.13


  • Source maintenance
  • Enabled spotlight shadows in PBR DrawStyle
  • Fixed issues with Face Transfer pane widget/layout log warnings

DAZ Studio : Incremented build number to 4.12.2.14


  • Source maintenance
  • Update to Qt 4.8.7.4 - patched SSL/TLS support
  • Extended DzAsset scripting API; added notes property
  • Updated public API documentation; DzAsset

DAZ Studio : Incremented build number to 4.12.2.15


  • Source maintenance
  • CLI open file commands are now logged

DAZ Studio : Incremented build number to 4.12.2.16


  • Source maintenance
  • Added support for CLI dsopen file open scheme

DAZ Studio : Incremented build number to 4.12.2.17


  • Source maintenance
  • Made adjustments to handling of CLI dsopen file open scheme

DAZ Studio : Incremented build number to 4.12.2.18


  • Source maintenance
  • Update Filament to 1.8.0.1
  • Update CMS Connector to 4.9.3.48 - fixed a crash bug

DAZ Studio : Incremented build number to 4.12.2.19


  • Source maintenance
  • Extended DzNode public API; added getSingletonID(), getSingletonIDString()
  • Extended DzNode SDK API; added setSingletonID()
  • Extended DzScene public API; added findSingletonNode()
  • Extended DzGuid SDK API; added operator<()
  • Updated public API documentation; DzNode, DzScene
  • Updated SDK API documentation; DzGuid
  • Added support for the concept of a “singleton” type nodes to DzNode and DzScene

DAZ Studio : Incremented build number to 4.12.2.20


  • Source maintenance
  • Extended public API; added DzPhysicallyBasedDrawOptionsNode
  • Added a Create > “New Physically-Based Draw Options Node…” (DzNewPhysicallyBasedDrawOptionsNodeAction) action
  • A singleton node is now used for PBR DrawStyle scene specific settings

DAZ Studio : Incremented build number to 4.12.2.21


  • Source maintenance
  • Update Filament to 1.8.0.2 - disables mipmapping for the PBR DrawStyle (temporary?) to facilitate investigation into quality concerns

DAZ Studio : Incremented build number to 4.12.2.22


  • Source maintenance
  • Fixed default values for PBR DrawStyle scene specific settings
  • Reintegrated the Physically-Based Rendering (PBR) DrawStyle plugin, and supporting libraries/resources, into the public Win64 footprint - re-initiate testing

DAZ Studio : Incremented build number to 4.12.2.23


  • Source maintenance
  • Adjustments to default values for PBR DrawStyle scene specific settings
  • Added the Physically-Based Rendering (PBR) DrawStyle plugin to the public Mac64 footprint
    • The PBR DrawStyle is disabled (due to OS SDK/Qt version conflicts), as is the “New Physically-Based Draw Options Node…” action, but asset IO is enabled in order to preserve DzPhysicallyBasedDrawOptionsNode scene data

DAZ Studio : Incremented build number to 4.12.2.24


  • Source maintenance
  • Relabeled the OpenGL related entries in the “Engine:” selector on the Render Settings pane
    • “Basic OpenGL” is now labeled “Viewport”
    • “Intermediate OpenGL” is now labeled “Multi-pass OpenGL”
    • The introduction of DrawStyles that are not necessarily OpenGL based (e.g., Filament/PBR), but can be used to perform a 'render' prompted this change
  • Update to Filament 1.8.0.3 - increases number of supported spotlight shadows from 2 to 6
  • Updated public API documentation; DzRenderOptions

DAZ Studio : Incremented build number to 4.12.2.25


  • Source maintenance
  • Update to Filament 1.8.0.4
  • Added support for instance nodes and instance group nodes to the PBR DrawStyle
  • Added the Physically-Based Rendering (PBR) DrawStyle plugin to the public Win32/Mac32 footprints
    • The PBR DrawStyle is disabled, as is the “New Physically-Based Draw Options Node…” action, but asset IO is enabled in order to preserve DzPhysicallyBasedDrawOptionsNode scene data

DAZ Studio : Incremented build number to 4.12.2.26


  • Source maintenance
  • Build system tweaks
  • Fixed an issue with material updates in the PBR DrawStyle
  • Updated default menus
    • Recommend clicking the Window > Workspace > Update and Merge Menus action

DAZ Studio : Incremented build number to 4.12.2.27


  • Source maintenance

DAZ Studio : Incremented build number to 4.12.2.28


  • Source maintenance
  • Updated images
  • Updated the default menu for the “Send to Bryce…” action to File > Send To
    • Work toward consolidating a growing number of “bridge” type actions
  • Updated the default menu for the “Send to Hexagon…” action to File > Send To
    • Work toward consolidating a growing number of “bridge” type actions
  • Updated the default menu for the “Send to ZBrush…” action to File > Send To
    • Work toward consolidating a growing number of “bridge” type actions
  • Updated the default menu for the “Initialize Photoshop 3D Bridge” action to File > Send To
    • Work toward consolidating a growing number of “bridge” type actions
  • Updated default menus
    • Recommend clicking the Window > Workspace > Update and Merge Menus action

DAZ Studio : Incremented build number to 4.12.2.29


  • Source maintenance

DAZ Studio : Incremented build number to 4.12.2.30


  • Source maintenance
  • Update to NVIDIA Iray RTX 2020.1.0 (334300.2228)
    • Increases minimum driver requirement (on Windows) to 451.48 - to properly support CUDA 11 and OptiX 7.1
    • Failure to update to the minimum driver is likely to produce a blank image
    • Installing updated driver may require restart (multiple)
  • Made changes (i.e., additions, modifications) to Shader Mixer low-level MDL bricksthat correspond to integration of NVIDIA Iray RTX 2020.1
    • Added DzMdlBaseBlendNormals, DzMdlBaseWorleyNoiseInput4, DzMdlBaseWorleyNoiseInput7
    • Manually recreated DzMdlBaseWorleyNoiseInput3, DzMdlBaseWorleyNoiseInput6 to preserve backward compatibility

DAZ Studio : Incremented build number to 4.12.2.31


  • Source maintenance
  • Updated SDK version to 4.12.2.32; SDK min is 4.5.0.100

DAZ Studio : Incremented build number to 4.12.2.32


  • Source maintenance
  • Updated public API documentation; DzAssetMgr

DAZ Studio : Incremented build number to 4.12.2.33


  • Source maintenance
  • Updated copyright statements in tools
  • Updated SDK samples

DAZ Studio : Incremented build number to 4.12.2.34


  • Source maintenance

DAZ Studio : Incremented build number to 4.12.2.35


  • Source maintenance

DAZ Studio : Incremented build number to 4.12.2.36


  • Source maintenance
  • Performed SDK samples audit
    • Support for publishing CMake based Daz to Unreal github project
    • Fixed inconsistencies/errors
  • Updated public API documentation; DzScene

DAZ Studio : Incremented build number to 4.12.2.37


  • Source maintenance

DAZ Studio : Incremented build number to 4.12.2.38


  • Source maintenance
  • Updated scene loading from the DzScene API to handle all current native formats instead of being limited to the deprecated *.daz format
  • Updated SDK API documentation; DzScene
  • Updated public API documentation; DzScene, DzContentMgr

DAZ Studio : Incremented build number to 4.12.2.39


  • Source maintenance
  • Fixed an issue where (mesh) modifier animation data (e.g., morph, dForm, bulge, legacy joint bending, legacy rigging properties, etc) would be omitted when saving a scene

DAZ Studio : Incremented build number to 4.12.2.40


  • Source maintenance
  • A singleton node is now used for Tonemapper settings
    • Scenes that contain render settings will automatically cause the singleton node to be created/replaced
    • Application of a Render Settings Preset will cause the singleton node to be created/replaced
    • The first render performed with the NVIDIA Iray renderer will cause the singleton node to be created
    • Create > New Tonemapper Options Node… will cause the singleton node to be created/replaced
  • A singleton node is now used for Environment settings
    • Scenes that contain render settings will automatically cause the singleton node to be created/replaced
    • Application of a Render Settings Preset will cause the singleton node to be created/replaced
    • The first render performed with the NVIDIA Iray renderer will cause the singleton node to be created
    • Create > New Environment Options Node… will cause the singleton node to be created/replaced
  • Extended DzScene public API; added singletonNodeAdded() signal
  • Extended DzRenderer public API; added renderElementsChanged() signal
  • Updated SDK version to 4.12.2.41; SDK min is 4.5.0.100
  • Added the NVIDIA Iray plugin to the public Win32/Mac32 footprints
    • This does not add/enable the NVIDIA Iray render engine, the NVIDIA Iray DrawStyle, MDL related capabilities, or the related Create > “New Iray Decal Node…” and “New Iray Section Plane Node…” actions, it enables preservation of DzTonemapperNode and DzEnvironmentNode scene data (created in Win64/Mac64 environments) during asset IO operations
  • Fixed an issue with a map assigned to a linked property not forwarding the map assignment to the other property in a 1-to-1 link

DAZ Studio : Incremented build number to 4.12.2.41


  • Source maintenance
  • Updated default menus; recommend clicking the Window > Workspace > Update and Merge Menus action

DAZ Studio : Incremented build number to 4.12.2.42


  • Source maintenance
  • Fixed an issue where the aniMate 2/Lite pane was modifying the playrange of the scene even when the pane was not visible (i.e. not the top-most pane in a visible pane group) or in use
    • This behavior only exhibited once the pane had been shown in the UI and then persisted for the remainder of the session
    • If the pane was not present in the layout on launch (e.g., it was closed prior to closing the application and so was not present when next launched), the behavior was not exhibited until shown (per above)
  • Extended DzNode public API; added addNodeModifier(), removeNodeModifier(), moveNodeModifier(), removeAllNodeModifiers(), getNumNodeModifiers(), getNodeModifier(), findNodeModifier(), findNodeModifierIndex(), findNodeModifierIndexFromEnd(), getUniqueNodeModifierName(); added nodeModifierAdded(), nodeModifierRemoved(), aboutToAddNodeModifier(), nodeModifierStackChanged() signals
  • Extended DzNode SDK API; added nodeModifierIterator(), nodeModifierDuplicate()
  • Modified DzNode public API; renamed addModifier(), removeModifier(), moveModifier(), removeAllModifiers(), getNumModifiers(), getModifier(), findModifier(), findModifierIndex(), findModifierIndexFromEnd(), getUniqueModifierName(); renamed modifierAdded(), modifierRemoved(), aboutToAddModifier(), modifierStackChanged() signals
  • Modified DzNode SDK API; renamed modifierIterator(), modifierDuplicate()
  • Updated SDK version to 4.12.2.43; SDK min is 4.5.0.100
  • Updated public API documentation; DzNode
  • Fixed a regression issue (#DS-2145/CS 337758) where use of published DzDForm API in scripts was resulting in an “ambiguous call of overloaded function” error

DAZ Studio : Incremented build number to 4.12.2.43