User Tools

Site Tools


This page exists within the Old ArtZone Wiki section of this site. Read the information presented on the linked page to better understand the significance of this fact.

From Renders to Layers

Author: White_Star

Tools Needed

  • DAZ Studio
  • Photoshop

Introduction

Sometimes the creativity that goes into an image is limited by the amount of computer memory (RAM) available to render the image.

In this tutorial I will outline a process whereby a scene in DAZ Studio can be broken into smaller parts, rendered separately (along with mask rendering), and loaded into Photoshop to reconstruct the complex scene. All without sacrificing those creative ideas at the hand of limited memory!

Step 1 - PLAN INDIVIDUAL RENDERS

Having designed a scene, complete with all required figures and objects in DAZ Studio, save the file (eg. Complete.daz), and start looking for objects that can be saved as groups for separate renders (hereafter referred to as 'subrenders'). In deciding which objects should be grouped together you will need to consider such memory consuming factors as the size of the object or its mesh, the level of texturing that the object may need (including any requirements within the surfaces tab), and whether shadows are used or not. Combining a number of high memory objects, or textured objects is not going to improve your render time or your computer's capability of completing the subrender.

You will also need to consider where shadows would fall in the scene (if using them) and most importantly, the organization of objects obscuring or overlapping other objects. (It would be meaningless to group objects together from the foreground with objects in the background on the same subrender as a great deal of editing would need to be done on fore and background renders in Photoshop to allow for the midground objects).

Step 2 - SAVE THE SUBGROUPS

To set up the first subgroup of objects, you will need to delete all objects from the Scene Pane except for those that are required within the first subgroup (for the first subrender). Be sure not to delete any cameras or lights that will be used within these individual subgroups.

Once this is accomplished, this should be saved using the render number and the scene contents as part of the filename for ready reference within other programs (eg. Sub1vic.daz would be the first subrender featuring Victoria). For this tutorial, I am choosing Victoria as she is the closest figure/object to the camera. The reason for this will become obvious later on.

Once saved, press Ctrl+Z (Undo) repeatedly to bring back all previously deleted objects to the original scene again. Objects that are not required for the second subgroup now need to be deleted, with the remaining objects being saved (eg. Sub2*.daz).

This process should be repeated for as many times as there are groups of objects to subrender.

Step 3 - RENDER TIME!

Before completing any rendering, it is often wise to clear the current scene totally by opening the File menu and selecting the New option, as the history of previously deleted objects will still consume memory that may affect the success of your rendering.

Load sub1vic.daz again, select the desired Render Settings and click Render. Save the image as sub1vicJPG.

400-02db2.jpg

Step 4 - CREATING A DAZ STUDIO MASK RENDER

In order to easily select and position Victoria later in Photoshop, we now need to create a Mask Render of sub1vic.daz.

Do this by selecting each light in turn, and in the Parameters Pane turn Illumination to Off.

400-02dc2.jpg

When completed, this will cause all objects to appear as black silhouettes – perfect for our mask rendering.

400-02dd2.jpg

For that extra 'mask' look, click the Viewport Options (to the left of the Viewport selection dropdown) and select Background Color. Set this to White and click OK.

Render your mask using the same settings as the sub1vic.daz original subrender, and save this as sub1vicmaskJPG.

Step 5 - COMPLETE RENDERS (ORIGINAL AND MASK) FOR ALL SUBGROUPS

Steps Three and Four need to be followed for all subrenders (masks included) before moving into Photoshop.

Step 6 - CREATING A MASK IN PHOTOSHOP

Load sub1vicJPG and sub1vicmaskJPG into Photoshop.

Select the sub1vicJPG window and in the Layers pane right click on the Background layer, select the 'Duplicate Layer'' option, name the layer Victoria, and click OK. Now click the Eye on the Background layer to cancel its visibility.

400-02de2.jpg

By doing this we ensure that we will later be able to see the characteristic checker pattern that indicates transparency in Photoshop.

Now we are going to use the sub1vicmask image within an Alpha Channel in order to accurately select Victoria from the solid color surroundings of the sub1vic image.

Select All of sub1vicmask in Photoshop (Ctrl+A) and press (Ctrl+C) to copy this to the clipboard.

With the original sub1vic window active, go to the Window menu and click Show Channels option. At the bottom of the Channels tab, click the 'Create new channel' button.

400-02df2.jpg

When Alpha 1 appears (black screen), press Ctrl+V to Paste the sub1vicmask image into the channel.

Click the RGB channel at the top, and return to the Layers tab for the final stage (to the left of the Channels tab).

Step 7 - USING ALPHA CHANNEL SELECTION

STEP SEVEN: USING ALPHA CHANNEL SELECTION

We are now going to remove the solid color from around Victoria so that she will reside on a transparent film that will allow the display of other layers (the other subrenders) behind her. (Hence, choosing the closest object to the camera for this tutorial).

Click on the Select menu, then the Load Selection' option. The Load Selection window appears, displaying the document name (sub1vicJPG) and a Channel selection dropdown beneath this. Set the Channel dropdown to Alpha 1, and click OK.

400-02e02.jpg

Pressing the Delete key will erase all image information surrounding our mask selection of Victoria (all the area surrounding Victoria which was white in the Alpha channel mask).

The first subrender is now reconstructed in the desired position from our original DAZ Studio scene. This process (steps 6 and 7) needs to be repeated for all other subrenders. Each successive subrender will become a layer, just like the sub1vic one has, with layers higher up in the Layer tab being displayed in the image window behind those layers at the bottom of the Layer tab.

400-02e12.jpg

Step 8 - FINAL NOTES

In Photoshop, the layer order can be altered by dragging a layer up or down, while duplicating layers and use of the eraser, can result in the sometimes necessary separation of parts of the same objects across a number of layers to correctly represent the original image (as displayed in DAZ Studio).

Another point to note, is that once selected, the black and white areas of the Alpha channel mask can be inverted by pressing Ctrl+I. With such objects now white, this will allow the object area itself to be deleted leaving a transparent hole in the selected layer. An alternative to switching the black and white areas within the Alpha channel mask, would be simply to use the Select menu's Inverse option (Shift+Ctrl+I).

Finally, feathering may need to be used depending on how your mask allows edges to be displayed alongside other objects. If there is a fine white line appearing around an object after its surrounding area has been deleted through the above process, undoing and applying a feather of 0.2 pixels will eliminate this hard edge giving a more natural appearance. Select menu – Feather (ALT+Ctrl+D).

This process seems a lot of work but is not too time consuming and can often be the difference between a great image that makes it into the 3D world and those that never get rendered due to memory limitations.

Happy rendering!