User Tools

Site Tools


This page exists within the Old ArtZone Wiki section of this site. Read the information presented on the linked page to better understand the significance of this fact.

Compositing Rendered Stills Over Photographs

Author: RSchrand

Support Files

Introduction

One of the really fun things to do with a rendered Poser model is to composite it onto an existing image, such as a photograph. We've all seen the creative ways users have done this'from placing Victoria (2/3) and/or Michael into a living room or an overlook, to having a sultry vixen wrapping her arms around the artist. If it's just for fun, the little details that make the scene realistic can be overlooked. But if you want the viewer to wonder if you went to the trouble of finding a living, breathing Victoria/Michael look-alike, then there are many details that have to be taken into account before the rendering process occurs.

This tutorial will follow my progress in utilizing the Gobbles character as he/she/it is used as a mascot for a local gaming store (which is why you see a logo t-shirt on the creature). The first part deals with building a still image; but future tutorials will look at how Gobbles will be incorporated into a television commercial we are producing.

Step 1 - Know Your Source File

400-02363.jpg

Before you begin setting up your Poser file, you want to get to know your source image (the photograph in which your character will be placed) intimately. Let's use Figure 1 above for an example.

This shot was taken with a digital camera using its built in flash as well as the store's fluorescent lighting. We are going to want to place Gobbles so he is standing on the table – he is a little cuss, y'know – so he looks like he's interrupting the intense gaming taking place.

The first thing is to determine the overall lighting by looking closely at the shadows in the image. Figure 2 shows a rough estimation of this. Two fluorescent lights fill the overall area with light. The camera lens was at table height, so the flash was lighting the scene from underneath, softening and often removing shadows the fluorescents created.

400-02373.jpg

Now let's look at the shadows that are still in the image. The two most prominent are on the guy's face (background left) and on the forearm (front left). We can see that the lighting we create should create a shadow that mostly faces downward, but is canted slightly to create a shadow on the screen left portion of the character (or on its right side, if you prefer).

400-02383.jpg

The nice thing about this image is that I set it up to emulate the base lighting in Poser. Yes, you could say that's cheating, but I am a firm believer of doing things in such a way as to make my work go faster, which then allows me to take on more projects and, ultimately, make more money! The complicated lighting set-ups come in another tutorial. All we want to do here is get you to look carefully at the scene in which you're going to place your character(s) so you can create the most realistic composite possible.

Step 2 - Build the Pose

400-02393.jpg

If you have the Gobbles character, build a pose like you see in Figure 4. Don't worry about the t-shirt texture—that's copyrighted and you can't use it! (Just kidding.) This is a still from the animation I created that will be used in the television commercial for the store—the non-composited version of which you can see by clicking here.

Note: You will need QuickTime to view this video.

If you don't have the Gobbles character, use any model you want.

Because I made sure to emulate the base lighting in Poser for the photograph, you don't have to mess with the lighting at all.

Render the file as a Photoshop, PICT, or TIF document—not as a JPEG. Even though JPEG makes smaller files, it's a 'lossy' format; you'll lose color information that can really mess you up if you want to take your file to a professional printer.

Step 3 - The Base Composite

400-023a3.jpg

Once the file is rendered, open Photoshop (or your image manipulation program of choice) and prepare to have some fun. From this point, I'll be discussing Photoshop 7, so some of the controls in other packages might have different names. Please refer to your program's manual if you can't find the same controls.

Open both the Poser image and the gaming image (which you can download by clicking here).

  1. With the Poser image active, use the Magic Wand tool to select the background color.
  2. Go to Select > Similar to have Photoshop select the rest of the same color in the file. All instances of the background color should be selected.
  3. Go to Select > Inverse or use Cmd/Ctrl + Shift + I to invert the selection. This will make the character the selected element and not the background.
  4. Drag the Poser character with the Move tool onto the gamers.tif image file and position him similar to what you see in Figure 5 above.

Gobbles (or your Poser figure) is located on a separate layer so you can easily manipulate it. At this point you have made the base composite, but there is still some work to do.

Step 4 - Adding a Shadow

400-023b3.jpg

While good ol' Gobbles (or whomever) is now a part of the image, he doesn't look like part of the image—yet. You're missing some important elements, the most glaring of which is a shadow on the board/table. The way I create shadows is probably different from many of you; I'd bet good money (up to 5-cents, big spender that I am!) that most of you use the Layer Styles controls to make your drop shadows. That isn't going to work for this—at least not easily and efficiently. To make the 'ground' shadow, do the following:

  1. Duplicate the Gobbles layer (which should be Layer 2 in the Layers window).
  2. With the bottom-most Gobbles layer active (Figure 6 above), go to Edit > Fill. Select Black as the Fill Color and make sure Preserve Transparency is checked (Figure 7 below). Then click OK. This fills the Gobbles image, but keeps the transparent areas around it.

400-023c3.jpg

  1. Now go to Filter > Blur > Gaussian Blur and set the blur to 8. Click OK.
  2. Choose Edit > Transform > Distort and distort the shadow layer so it looks like you see in Figure 8. I have left the bounding box visible so you can better recreate the ground shadow.

400-023d3.jpg

  1. In the Layers window, change the layer's opacity to 30%

Step 5 - Adding a Shadow (contd)

400-023e3.jpg

If you think the blur's edges are too sharp, feel free to go back to Filter > Blur > Gaussian Blur and add to the softness until your happy with it. But your file should look like you see in Figure 9 above with the Blur setting of 8 (previous step).

You probably noticed that I manipulated the shadow area so it goes a little bit behind the character. That goes against the light source, but works perfectly when the shadow's opacity is reduced; extreme edges often disappear during the opacity change and, in this case, gives the appearance of its being underneath Gobbles, retaining the semblance of reality to the scene.

Another thing you can add to the shadow layer is a little bit of Noise. Give it a try. Go to Filter > Noise > Add Noise. Keep the amount low – no more than a setting of 7 – and see how that interacts with the scene.

Step 6 - The Final Touch

400-023f3.jpg

There is one more thing to do to Gobbles before he's ready for final positioning.

Question: Why does a computer-generated composite ALWAYS look like a computer-generated composite?

Answer: Because the edges are too sharp.

We really don't see sharp edges. We see the end of one object and the beginning of another object, but there's some softness to the edges because of the bounce of light and the blending of colors from one shape to another. Look closely at any photography or at anything in your office or house. Look very closely. There's a very slight softness to the edges of most everything you look at. So how do you emulate that in your images?

  1. Use the Magic Wand tool and select the transparency in the top-most Gobbles layer. Then use Select > Similar to select the rest of the transparency.
  2. Go to Select > Modify > Expand, and expand the selected area by 2 pixels. This will expand the 'marching ants' into Gobbles slightly.
  3. Now go to Select > Feather and set this to 1. The trick is to feather the edges no more than 1/2 the pixels of Expand.
  4. Hit the Delete key on your keyboard.

You have now softened the edges of your character, making it appear more like it's a part of your photograph. (Figure 10 above)

Step 7 - Closing Comments

400-02403.jpg

That's it—for the most part. You could leave the character in the foreground, even though the foreground is out of focus. It's not totally realistic that way, but sometimes you can cheat. A cursory look at the image feels fairly realistic. But if someone looked closely, they would see this problem. So you might want to move Gobbles/your character to another location, and either cut out portions of him to blend into the scene, or copy and past elements from the picture onto another layer to complete the picture. You can see what I mean in Figure 11 (above).

With some practice, you can train your eye to see the smaller details that many people often overlook. This will ultimately set your work above the rest that's being displayed out there. And by looking at the small details, your value as an artist will increase dramatically.