User Tools

Site Tools


This page exists within the Old ArtZone Wiki section of this site. Read the information presented on the linked page to better understand the significance of this fact.

Create a custom Photoshop CS brush

Author: taniab

Tools Needed

  • Photoshop

Introduction

This tutorial shows how to create different types of custom Photoshop brushes. I've used Photoshop CS, but it should work with Photoshop from version 7 and up. I suppose you are familiar with Photoshop tools and menu. In the following something like Edit > Copy means: “open the Edit menu and click on the Copy command”.

Step 1 - Our first brush

Open Photoshop and create a new document abut 100×100 pixels, background color white or transparent.

300-0198.jpg

Click on the brushes palette and choose a small brush (hard or soft depends if you want a new soft edged or hard edged brush), black color and start drawing. I want to create a new brush with an irregular tip, so I make something like in figure 2.

300-0199.jpg

When you are done, go to the menu Edit > Define brush preset ….

A dialog appears showing a thumbnail of the new brush with its size and asking for a name: type whatever you want and click OK. Your new brush is at the bottom of the brush palette and it's already selected as a new brush tip.

300-019a.jpg

You can create a new document (bigger than 100×100, for example 500×500) and try your new brush with different color and/or different opacity and flow settings to see if you like or if it needs some adjusting.

Step 2 - Creating a custom brush set

Now there's some work to do here: we want to create our own set of custom brushes, so we need to get rid of all the currently loaded brushes. You have to manually do this for each brush: Right-click (Ctrl+click for Mac) on each brush, except the one we have just created, and select “Delete” from the popup menu. Click on OK in the dialog that appears.

300-019b.jpg

When you are going to create a new brush set, I suggest you load a set that contains a few number of brushes before starting. Or you can create a custom brush set with only one brush and use it every time you need to create a custom set (you can't' have an empty brush palette in Photoshop).

When you are done deleting all the brushes you are ready to save your set:

when you select the Paintbrush tool, the options bar changes to show all the options for that tool. Click on the little black arrow next to the brush tip (upper left corner of screen: far left in the options bar): a palette showing all available brushes, plus some options for them becomes visible. Click on the little black arrow on this new palette and you see a menu with different options that allows you to manage your brushes: different view options, load brushes, save brushes, etc. plus some preset brushes that come with Photoshop (at the bottom of the menu). This is where we will go to save our new custom brushes.

Click on “Save brushes …” a dialog appears asking for a name and location for the set. I'm going to spend a few words about this.

Photoshop brushes are usually located in the folder Presets\Brushes located in the main Adobe Photoshop folder: all brush sets saved here will be immediately accessible from the palette menu.

I usually save my custom brushes in a different folder (for example MyDocuments\MyPhotoshopBrushes\Category): this way I don't fill up the Photoshop folder and I always keep track of custom brushes. And I follow the same criteria for downloaded brushes: I keep them organized by creator and category (flowers, grunge, etc.) along with a copy of the readme to be always sure of the license of use.

It's up to you were you want to save: if you like to have quick access from the brush palette menu, save in the Adobe Photoshop\Presets\Brushes folder. Or choose a different location: in this case you can load customs sets by selecting “Load brushes …” from the menu and locating your brushes in the “Load” dialog.

Now, back to our set: choose a name for your set (note that Photoshop uses the .abr suffix for brushes: keep it), choose a location and click “save”.

300-019c.jpg

Now we can go on and add more brushes to this custom set.

Step 3 - Creating a brush from a photo

First we need a nice photo, I got one of a flower (from imageafter). I've used the magnetic lasso tool to select only the flower (I could use the magnetic lasso because there's enough contrast between the main subject and the background). Then Selection > Feather about 5 pixels (see what's best for you) to get a soft edge around the flower. Selection > Invert to select the background and finally hit Delete key to remove it. Be sure to have the background color set to white before deleting, in case you don't hit D on the keyboard to reset the default Photoshop foreground and background colors.

300-019d.jpg

Then I zoomed in the image and used the eraser tool to remove any leftover spots around the contour of the flower.

300-019e.jpg

Since our image is too big to create a brush we need to resize it. In this case I want a quite big brush, so I'm going to Edit > Image size and resize to around 200-300 width, checking “keep proportions” so it won't be distorted.

Next step is to convert the image in grayscale and adjust brightness/contrast (both are found in the Image menu and submenus). Here's is what we get:

300-019f.jpg

It's time to save our new brush, following what we did in step one: Edit > Define brush preset…. give a name and save.

300-01a0.jpg

Step 4 - Creating a brush from a custom shape

Here is just another example of a custom brush. I'll go quickly here.

We will use one of the custom shapes that come with Photoshop and apply a layer style to it, before defining our custom brush.

Create a new image 300×300, choose the custom shape tool, choose heart and draw your shape.

300-01a1.jpg

Now this is what I did:

On the layer palette Right-click (ctrl-click if mac) on the shape layer and choose “rasterize layer”.

Ctrl+click (Command-click if mac) on the same layer to load the shape as a selection.

Choose a gradient you like and fill the heart.

Apply a layer style from the layers menu: I have created an emboss effect.

300-01a2.jpg

Turn the image to grayscale and Edit > Define brush preset.

Here's a few examples with our new brush: I have changed color, size and opacity settings to create different effects.

300-01a3.jpg

Step 5 - More options

Once you have created your custom brushes, you can use them as starting point for new ones. For example you can create different sizes of the same brush and save them so you can access them quickly: just select the brush, change the size and save as explained below.

300-01a4.jpg

But you can adjust even more options for your brushes. If you click in the brush palette (far right of the options bar) you see a lot of options for you brushes with different settings: just choose the settings you need and save as a new brush. I'll show just one, the scattering option, as an example. NOTE: If you have changed the default Photoshop interface you may have this palette located somewhere else.

Choose one of the brushes, I'll use the hearth, click on the brush palette in the option bar to open it and select “scattering”. Play with the settings.

300-01a5.jpg

When you are done save your brush: click on the brush selection menu and then on the little square under the black arrow: this saves a preset brush with all the options selected on the brush palette.

300-01a6.jpg

Create a new document and try your new brush: all this hearts were created with two mouse clicks!

300-01a7.jpg

Step 6 - Conclusion

As you can see there are a lot of ways to create custom brushes and different settings to try out. It would be too long to explain them all, so I've tried to give you some starting points. Now go, experiment and have fun!