User Tools

Site Tools


This page exists within the Old ArtZone Wiki section of this site. Read the information presented on the linked page to better understand the significance of this fact.

Lesson 2: Working with Phonemes

The phoneme system is the core of Mimic's functionality. A phoneme associates a sound with mouth and other facial morph targets (figure deformations) that cause the figure to create realistic movements. Figure creators such as DAZ set up morph targets to closely match how the mouth looks when making a specific sound. A phoneme can contain anywhere from one to a dozen morph targets. DAZ's Millennium Figures are fully set up to work within Mimic. Some of the default figures included with Curious Labs Poser version 3.0 and higher also include some of these customized morph targets.

Mimic's primary function is to automatically match up a sound file to the corresponding phoneme set, thus freeing up animators from countless hours of tedious work. Mimic 3.0 allows you to edit phonemes directly within the Timeline, giving artists much greater power and flexibility to fine-tune their animations before exporting them to either DAZ Studio or Poser for final rendering.

To begin this tutorial, load the Mimic session file you created in the previous tutorial by selecting File > Open and navigating to the correct folder and file. If you have not exited Mimic since completing the last tutorial, then you may simply proceed to the next step.

Step 1: Getting Ready

The first step is to identify the two portions of the Mimic interface that we'll be focusing on during this tutorial. The first is the Phoneme Track in the Timeline, which is where the phonemes actually do their work. The second is the Phonemes section of the Phonemes and Expressions window. Add phonemes to your animation by clicking and dragging your selected phoneme from the Phonemes and Expressions palette to the Phoneme Track.

Editing or customizing a phoneme involves adjusting the morph targets that are associated with that phoneme. You can add custom morphs into one or more phonemes as desired, then save the result as a customized Mimic (.dmc) configuration file, which you can then use in other sessions or distribute to other Mimic users.

Step 2: The Phoneme Definition Window

This example uses the stock morphs included in the Victoria 1 figure that ships with Mimic. Each figure will include different morphs and you should either create or load a custom configuration file for each figure to ensure maximum lip-synching fidelity. For example, if you are working with the DAZ Victoria 3 figure, you should load the victoria.dmc file in the Mimic Configuration_Files folder. For this tutorial, let's stick with the default.dmc file.

In the Phonemes and Expressions window, scroll through the Phonemes section until you locate the + EH (Ed) entry. All phoneme entries use the following syntax:

  • Expand/Collapse: Phonemes are displayed in a tree view, with copies appearing on sub-branches.
  • Sound: Sound made by the selected phoneme.
  • Pronunciation: How the specific sound is pronounced. This information is important because there can be several ways to pronounce certain letter combinations depending on the word and language.

    t2_ehed.jpg

From the explanation, you can see that the + ED (Ed) entry means the following:

This particular phoneme has one or more copies underneath it. Clicking the + sign displays the copies of this particular phoneme, including EY, AE, and AW. In this case, the phoneme creators felt that those sounds produced facial movements so similar to the EH sound that they simply copied those movements to the other phonemes. Try double-clicking one of the copied phonemes and looking at its Phoneme Definition window. To customize a copied phoneme, click the Uncopy button and assemble a new set of morphs. For this tutorial, we'll work on the AW phoneme. This phoneme is for the “Eh” sound as pronounced in the words “Ed” or “Elephant”.

Step 3: Visualizing Phonemes in DAZ Studio or Poser

The first step is to load the figure into either DAZ Studio or Poser.

icon-tip.jpg TIP! Already familiar with the morph targets you're using for your new phoneme? If so, you can skip this step and move directly on to the next step. Mimic allows you to do all of your configuration setup directly within the application, eliminating the need for DAZ Studio or Poser for this purpose (you still need either DAZ Studio or Poser for final rendering). You can even preview your work in the Preview window! Clicking the Preview button in the Phoneme Definition window temporarily changes the figure in the Display window to show what the current phoneme looks like.

Importing Figures into DAZ Studio

If you are using DAZ Studio, go ahead and launch the application, then import the default Mimic figure as follows:

  1. Select File > Import from the menu.

    t2_fileimport.jpg
  2. Navigate to the Configuration_Files folder under your Mimic installation (such as C:\Program Files\DAZ\Mimic\Configuration_Files).
  3. Select the default.cr2 file and click on Open.

    t2_defaultcr2.jpg

    Each character (.cr2) file contains morph and joint information for the figure referenced by that file. If you do not see any CR2 files, change the file type to Poser Files.

    t2_selectfiletype.jpg
  4. If an Unable to locate file dialog appears, asking you to locate the blMilWomLoNG.obj file, which is the polygonal mesh object referenced by the character (.cr2) file imported in the previous step, click the Locate button to open a Browse dialog. The .obj file is in the same folder as the default.cr2 file.
  5. If the Unable to locate file dialog appears again, this time asking you to locate an image file (JPG). At this point, click the Skip All button to load the figure into DAZ Studio without its texture maps (images that add detail to an object's surface).

Importing Figures into Poser

Please refer to your Poser documentation for information on importing figures into Poser.

Adjusting Morph Targets

When creating a new phoneme, you would normally adjust the head morphs manually until you get the look you want, however, since we've already done the work for you, just follow the instructions below.

If you are using DAZ Studio, adjust the figure's head morphs as follows:

  1. Select the figure's head, then select the Parameters tab by clicking it.

    t2_selecthead.jpg
  2. Locate and set the following parameters:
    • Open Lips: 25%
    • Open Smile: 25%
    • Mouth 'A': 50%
    • Mouth 'O': 40%

      t2_setparameters.jpg

Your results should look like those in the image on the right.

t2_afterparamchange.jpg

Step 4: Creating the New Phoneme Definition

  1. In Mimic, be sure the AW phoneme has been uncopied from the EH phoneme as described in “Copying & Uncopying Phonemes.”
  2. The next step is to remove the existing definition. Do this by highlighting each listed morph target in the Channel list and pressing the Delete key.

    t2_deletemorphs.jpg

    Once you have deleted all of the existing morph targets, you are ready to add your new phoneme definition. Do this as follows:
  3. Click the Add more to definition button (or select Window > Object Tree) to open the Object Tree window, which displays a tree view of every body part on your currently selected figure. This tree displays the figure's hierarchy or sets of parent/child relationships. For a quick example of parent/child relationships, bend your arm at the shoulder and notice that your upper arm, elbow, forearm, hand, and fingers all move. Next, bend your elbow. Your shoulder remains still, with every part below your elbow moving. Your shoulder is the parent joint for your entire arm. Your elbow is a child of the shoulder and a parent to the rest of your arm.
  4. In the Object Tree window, double-click the Head entry to open the Object window, which lists all of the available morphs for the selected body part.

    t2_addmoredef.jpg
  5. In the Object window, scroll down to locate the morph targets you worked on in the previous step. For this tutorial, enter the following values in the Value Offset field:

    • Open Lips: .25
    • Open Smile: .25
    • Mouth 'A': .5
    • Mouth 'O': .4

      t2_offsetvalue.jpg

icon-tip.jpg TIP! Poser and DAZ Studio express morph target values in percent (0-100%). Mimic expresses morph values in decimals (0.0-1.0).

  1. Close the Object window followed by the Object Tree window by clicking the Close buttons at the upper right corners of both windows.
  2. Click the Preview button in the Phoneme Definition window. If you entered all the correct values for the correct morph targets, your figure should look just as she did in DAZ Studio or Poser. Here's a side-by-side comparison with DAZ Studio on the left and Mimic on the right.

    t2_compare.jpg
  3. If you like, the Color field allows you to specify a color for the phoneme so it stands out in the Phonemes and Expressions palette. To select a color, either click anywhere in the Color field or click and drag the slider inside the Color field.

    t2_phonemecolor.jpg
  4. The last item of interest in the Phoneme Definitions window is the Preview Strength slider. This determines how strongly the phoneme's morph targets will be applied when previewing the phoneme. A value of 100% displays the phoneme as you created it. Values less than 100% show a muted effect, and values greater than 100% show an exaggerated effect. For example, a value of 50% would be equivalent to setting all morph targets to 50% of their assigned values while a value of 200% is the equivalent of doubling the morph targets to twice their assigned values. For the purposes of this tutorial, we'll leave the Strength at 100%.

    t2_previewstrength.jpg
  5. When you are finished making your changes, close the Phoneme Definition window by clicking the Close button at the upper right corner.

Step 5: Saving Custom Configuration Files

Whether you work on an existing configuration file or want to save your changes for a later session, you'll want to save your new phoneme(s) to a new configuration file. Do this by selecting File > Save Configuration File from the menu. A standard Save As dialog box appears. Select your desired save file and filename, being sure not to overwrite any existing files.

icon-tip.jpg TIP! Remember that there are several ways to save your Mimic work. Saving a configuration (.dmc) file saves your phonemes, gestures, and expressions, but does not save your current session. To save your session for future use, save a Mimic session (.dms) file. Lastly, you can save multiple-frame pose files (.pz2) for use in DAZ Studio and/or Curious Labs Poser.

Step 6: Using Your New Phoneme

Now that you've created a phoneme, here's how to add it to the Timeline. You may either:

  • Select it in the Phonemes and Expressions palette and drag it to your desired spot in the Phonemes Track in the Timeline.
  • Select it in the Phonemes and Expressions palette, then right-click in the Phoneme Track and select Insert from the context menu.

Please see “Phonemes” for more information about working with phonemes.