User Tools

Site Tools


This page exists within the Old ArtZone Wiki section of this site. Read the information presented on the linked page to better understand the significance of this fact.

Lesson 1: Getting Started

This tutorial walks you through creating a basic Mimic lip-sync session and shows how Mimic makes some of the most complex animation very easy. Mimic is ready to go immediately after installation. It even includes a figure (a reduced-resolution version of DAZ's Victoria 1) and sample files to get you started!

icon-tip.jpg TIP! If you already own a Mimic-ready figure such as DAZ's Victoria, you may use that figure instead of the default Mimic figure. You will achieve much better results using figures designed specifically for use with Mimic.

icon-tip.jpg TIP! If you use figures that support injection morphs (such as DAZ's Michael and Victoria 3), be sure to only load the morphs you need. These are typically the head expression morphs, since that is what most artists use when creating animations in Mimic. Loading additional morphs requires additional computing resources and may will significantly increase the time required to load a figure into Mimic.

Step 1: Add Files

Begin this tutorial by launching Mimic. The first thing you'll see is the Session Manager. The Session Manager sets up Mimic sessions by loading source files and setting global options. You can edit and tune your session later.

Load Audio File

The first file we need to load is the sound file containing the audio we'll use for this session.

  1. In the Sound area, locate the Find Matching Text File label and make sure the radio button is selected. This allows Mimic to automatically load a matching text file (if it exists) when the sound file is loaded. The text filename must match the sound filename. If you do not have a matching text file, then this option will not do anything, but it won't hurt either.

    t1_findmatchingtextfile.jpg
  2. Click the Load File button in the Sound area at the top of the Session Manager to open a Browse dialog (the button appears as shown below). By default, the folder containing the sample sounds included with Mimic is selected.

    openwavbutton.jpg openaiffbutton.jpg
  3. Pick the work.wav file (PC) or work.aiff file (Macintosh) by selecting the desired file then clicking on Open or OK. Mimic will use this file as the basis for synchronizing the figure's movements. After loading the file, you'll notice some red blobs underneath the sound controls. This is a visual representation of the sound contained inside the selected file. It is called the waveform.

    t1_waveform.jpg

Load Text File

Next, we'll add a plain ASCII text file. This is an optional step that can both enhance the fidelity of the lip-synching and provide valuable reference points when working inside the Timeline. We'll be talking more about the Timeline in later sections.

If a matching text file was found, it should already be loaded into the Text area, but if not, do the following:

  1. Click the Load File button next to the Text area in the Session Manager and select work.txt in the same way you just selected the sound file.

    opentxtbutton.jpg
  2. Take a moment to read this file. Notice a few glaring spelling errors? Read the text aloud, paying special attention to how the spelling clearly defines how the words should be pronounced. In other words, writing “synchronization” as “sink row nih zation” means that it can't be pronounced as (for example) “cinch ron eye zation”. Some languages, English included, have complex pronunciation rules that are not always self-evident from a word's spelling. Mimic uses text files in conjunction with sound files to create lip-synched animation. If you're having problems getting the figure's speech to look right, try modifying your text file. This simple step can save you a lot of hassle and frustration.

    t1_textfield.jpg

Load Configuration and Character Files

By default, Mimic loads the default configuration and character files when a sound file is loaded. If you are using a figure other than the default one, you'll need to load the configuration and character files for that figure.

Mimic configuration files contain all of the necessary phonemes (vocalizations), expressions (emotions), and gestures (other head movements) that can add extra realism to your sessions.

Character files reference the 3D model and contain all of the information needed to make the figure move. At its root, a 3D figure is a single object that consists of many individual polygons assembled into the final shape. Posing and moving these solid objects requires the separate character file, which defines the locations and types of available motion. Character files have the extension .cr2 and were originally developed by Curious Labs for use in their Poser application. DAZ Studio supports the .cr2 format, meaning that you can use DAZ's figures in both DAZ Studio and Poser.

To load configuration and character files for the default Mimic figure:

  1. Click the Load File button in the Character File area of the Session Manager.
  2. Select the default.cr2 file from the Configuration_Files folder and click on Open.
  3. Click the Load File button in the Configuration File area of the Session Manager.
  4. Select the default.dmc file from the Configuration_Files folder, and click on Open.

    t1_configcharfiles.jpg

Step 2: Let Mimic Do the Work

After loading the files, take a moment to ensure that all five Gestures radio buttons at the bottom of the Session Manager are checked. Doing this will show off the power and ease of Mimic while making your work easy. Once you've checked the radio buttons, click OK to close the Session Manager and open the main Mimic interface. If you're using Mimic in conjunction with DAZ Studio or Poser, you will need to wait a few moments while Mimic analyses the figure. Subsequent changes will be much faster.

gestureselections.jpg

Step 3: Lip-Synching Made Easy

If you've followed the tutorial steps so far, the main Mimic interface will look as shown here.

t1_initialworkspace.jpg

To view your animation, click the Play/ Pause button (shown below) in the Timeline. The animation will loop until you click the Play/Pause button again.

playbackcontrols.jpg

Notice that the Display window only shows the figure's head and neck. 3D figures can require significant computing resources. By default, the configuration files included with Mimic hide most of the figure except for those areas affected by lip-synching.

Just like that, you've created a workable basic lip-synched animation using Mimic! Keep in mind that this tutorial is only a small peek at Mimic's powerful tools and functionality. We will explore these functions in later chapters. Meanwhile, let's finish our current session by exporting a multiple-frame pose file for use inside DAZ Studio or Poser.

Let's save our current session file for use in later tutorials. To do this, select File > Save. A standard Save As dialog appears, allowing you to select your desired folder and filename. Go ahead and save your session file in a convenient location.

Step 4: Using Mimic Animations in Other Applications

In order to use your Mimic animations with DAZ Studio or Poser, you must export them as animated pose (.pz2) files. Pose files have the extension .pz2 and were created by Curious Labs to allow artists to save figure poses for later reuse. These files support both single-frame (still) and multiple-frame (animated) data. Mimic uses animated .pz2 files to transfer your lip-synched animations between itself and DAZ Studio or Poser.

To save a pose file, select File > Export Pose (PZ2). A standard Save As dialog box appears, allowing you to select your desired folder and filename.

If you are using Poser, you will need to add your newly created pose file to that application's content library. Please refer to your Poser documentation for information on adding content to the library. It is important that you save the file in the correct folder in order for it to appear inside Poser. If you are using DAZ Studio, you may save the file in any local or network folder you like.

Step 5: Rendering the Final Movie

The final step in this process is to render your movie and see the final results. Please refer to your DAZ Studio and/or Poser documentation for rendering instructions.

icon-tip.jpg TIP! If you want to save your Mimic session for later use, select File > Save and select your desired folder and filename.

Step 6: Try it with Video

Before beginning this step, please be sure to save your work so far as a Mimic session file by selecting File > Save if you haven't done so already, or create a new session. Next, we'll load a video file that includes an audio track. We'll do this as follows:

  1. Open the Session Manager by selecting File > Session Manager from the menu.
  2. If you are continuing a previous session, you will want to remove the previous sound and text files. Do this by clicking the Remove File button in both the Sound and Text areas.

    closewavbutton.jpg closeaiffbutton.jpg closetxtbutton.jpg
  3. Having removed the old sound and text files, the next step is to load the video file. Click the Load File button in the Video area and select the sample Wait Until.avi animation.

    openvideobutton.jpg
  4. A Confirm window appears asking if you want to analyze the sound track contained in the video. Click Yes.

    confirmanalyze.jpg

    The Session Manager should now appear as shown here.

    t1_worksession2.jpg
  5. Click OK to set your preferences and exit the Session Manager into the main Mimic interface. Another Confirm window may appear asking if you want to overwrite your existing settings. Click Yes.

    confirmloadnewwav.jpg

    Your Mimic workspace should look like the image below when you're done. Notice the live-action video in the Video window next to the Display window.

    t1_workspace2.jpg
  6. Click the Play button in the Timeline and watch the animation and video side by side. Notice how realistic the Mimic animation is in terms of pronunciation and added extra touches like head movement and blinks.

    Then look at the live model and notice both the similarities and the differences. For example, the live model has a happy expression. Also, her head moves at different points in her speech. If you want your figure to duplicate the live model's acting, you can easily add and edit expressions and gestures. We'll cover this in more detail in later tutorials.

Step 7: Lights, Camera, Action!

Mimic allows you to control lights and add background images to your scene and then create movies in AVI (Windows), MOV (MacOS), or SWF (Flash) formats.

  1. Let's begin by loading a background image. Select File > Background Image to open the Background Image window. Click the Open File button (the folder icon) to open a standard Open dialog. By default, the dialog opens in the Mimic/Backgrounds folder so select anypicture from the folder to insert as a background. Your selected image appears in the Display window as shown here. Please refer to “Background Image” for more information.

    t1_backgroundimage.jpg
  2. Now let's add some custom lighting. Begin by selecting Window > Light Controls to open the Light Controls window. This window always displays eight lights.

    lightcontrols.jpg
  3. To control a light's brightness, select the light by clicking on it then drag the Brightness slider to the right (bright) or left (dim). Dragging the Brightness slider all the way to the left gives the selected light zero brightness.

    lightbrightness.jpg
  4. Clicking the Color button opens a standard Color Picker, allowing you to specify the desired color for that light. Try this with a few lights.

    lightcolor.jpg

    Here's an example of a green light.

    t1_greenlight.jpg
  5. Last, let's create a movie. Select File > Create Movie Preview to open the Video Preview Controls window.

  6. Click the Make Preview button.

    videopreviewcontrols.jpg

    The movie will take a few moments to create depending on the scene's complexity and length and your computer. When the movie is complete, you will see it playing in the Display window.

    t1_makepreview.jpg
  7. Now click the Save Preview to Movie button to open a standard Save As dialog box. Select a folder and name for your new movie, then use your regular playback application (such as Windows Media Player) to view your creation. Be sure to turn your speakers up!