User Tools

Site Tools


This page exists within the Old ArtZone Wiki section of this site. Read the information presented on the linked page to better understand the significance of this fact.

Simplifying Complex Background Props in DAZ Studio

Author: eallenmail

Tools Needed

  • DAZ Studio 1.8
  • Bookshelf prop with various book and plant and knickknack props on it
  • Adobe Photoshop [or comparable image editor]

Introduction

A complicated background prop, such as a shelf full of various books, uses a lot of geometry information, as well as texture files. Such a prop adds realism and detail to your renders, but takes up lots of memory, lengthening render time. Using D|S' Export as OBJ and Collect Maps features, you can reduce the impact of complicated props on your system, speeding up your renders. We'll be using a set of full bookshelves in this example, but this also works for dolls, messy desks, garages full of stuff, you name it!

Step 1 - Before we start, here is an important note.

The whole point of this tutorial is to take a bunch of single props with their own OBJ files and high-resolution textures and turn them into one OBJ with lower-resolution textures. You will not be able to move the individual parts of the resultant OBJ, but that is okay…it is just a background prop.

Step 2 - Open D|S and the full bookshelves.

If the full bookshelves are part of a scene file with other elements, delete all elements except the full bookshelves. Then save the full bookshelves as their own .daz file. If the full bookshelves are in their own scene file, great!

300-0088.jpg

Step 3 - Look at the scene tab just to see what you are dealing with.

As you can see, there are about 30 separate props on my full bookshelves. Some may be poseable characters with bone information; some may have morphs; all of them have textures, most of which are high-resolution. But, since we are just making a background prop, we do not need said bone information, morph information or the high-resolution textures. So we will simplify what we have.

300-0089.jpg

Step 4 - Export the whole thing -- that is, the full bookshelves and their contents -- as an OBJ.

Go to File > Export. Name the OBJ and browse to an appropriate location. [I am saving mine as “marksbooks.obj” in my Sets runtime > Geometries > Derived. I created the folder named Derived.] Make sure that you save the file as a Wavefront Object type.

Step 5 - Your Basic export settings should be as follows:

Preset = Custom

Scale = 100%

Do not export invisible nodes = should be checked

Weld figures = should not be checked

300-008a.jpg

Step 6 - Your Advanced export settings should be as follows:

Swap y and z orientation = should not be checked

Write UV coordinates = should be checked

Write normals = should not be checked

Write groups = should be checked

Use existing groups = should be selected

Use node names = should not be checked

Use figure names = should not be checked

Use surface names = should not be checked

Write surfaces = should be checked

Write material library = should be checked

No maps = should not be selected

Collect maps = should be selected

Convert maps (for Bryce) = should not be selected

300-008b.jpg

Step 7 - Once you have exported your OBJ, close out of D|S and open up Photoshop [or comparable image editor].

Browse to the location of your exported OBJ. In my case, the location is Sets > Runtime > Geometries > Derived. In the folder with my exported OBJ, marksbooks.obj, there is a Maps subfolder.

300-008c.jpg

Inside it has copies of all the texture and transparency map files used in the making of your OBJ – that is, the textures of all the books and other things filling up your bookshelves.

300-008d.jpg

Step 8 - Reduce the size and quality of all textures in Photoshop [or similar].

In Photoshop, I do this by opening each texture in turn and going to Image > Image size and reducing the size of each texture so that it is between 15 and 30% of the original size. The smaller the prop, the more I reduce the texture size. I also save the texture file as a medium or lower-quality JPG, rather than a high-quality one.

Step 9 - Once all textures and transmaps are reduced in size, reopen D|S.

Open the scene in which you want to place your bookshelves OBJ. Then go to File > Import and browse to the location of your OBJ. Your Import settings should be as follows:

Preset = Custom

Scale = 100%

Swap Y and Z orientation = should not be checked

Read groups = should be checked

Read UV coordinates = should be checked

Read surfaces = should be checked

Read material library = should be checked

300-008e.jpg

Step 10 - You now have a simplified background prop that looks realistic and adds depth to your renders without hogging memory or render time.

Remember that you cannot move the books off your bookshelves OBJ, and the bookshelves are not made for super close-ups, but they will do fine as background furniture. You can follow the same principles on other programs and other props besides full shelves. Like I said, you could make a bed full of stuffed animals, a display shelf full of knickknacks, and an attic full of treasures…whatever you want. And, with this tutorial, the complex prop doesn't have to be a memory hog.