Export As: [ PDF | ODT ]

The DAZ Studio Timeline Explained

Author: ByteMe72

Tools Needed

  • DAZ Studio 1.0
  • DAZ Studio Base Content

Introduction

This tutorial assumes that you have read the DAZ Studio manual and practiced the introductory tutorial presented there. You should be comfortable with the basic DAZ Studio interface before proceeding. This tutorial will expand on the information presented in the manual, in relation to animation. By the time you have completed this tutorial, you will have a basic grasp of how to produce motion in your characters, objects, and scenes and how to control that motion.

Step 1 - THE PARTS OF THE TIMELINE EXPLAINED

300-03ae.jpg

The image above shows the DAZ Studio Timeline, which can be opened by going to the Windows menu and selecting “Timeline” from the options presented. Alternatively, you can press Ctrl+6 (Command-6 in Mac OS X) to make the Timeline visible. Like any other pane in DAZ Studio, you can maneuver the pane anywhere you like on screen, or even “dock” it in place (such as at the top of the screen). Click on the bar along the top of the Timeline to drag it around.

The Timeline has two tracks: the Playrange Track in the top half and the Frames Track in the bottom half (most of the names in this tutorial are of my devising based on typical industry terms; DAZ may later write a proper manual with different names). The Playrange Track shows you how many of the total number of frames (in the entire animation) can be accessed in the Frames Track. The Frames Track allows you to actually select a specific frame (within the range specified). The reason for this is simple: your animation could be huge (potentially in the thousands of frames if you had enough memory and a fast enough computer). If all you had was the Frames Track, the Timeline would be so crowded with frames that you would have a hard time finding and selecting the one you want. By using the Playrange Track, you can “narrow down” the number of frames displayed in the Frames Track in order to make it more manageable. Using the Playrange Track in this way also limits the number of frames played when you preview the animation in the View Port, as will be described shortly.

The red triangle in the Frames Track is the Timeline Slider control (I usually just say “Timeline Slider, ” or sometimes the “Scrubber”). The Timeline Slider marks the frame you are currently working in. You can move to a different frame by clicking and dragging the Timeline Slider to the new frame (this action is called “scrubbing” by some people, hence the nickname “Scrubber” for the control itself). Alternatively, you can just click in the Frame Track at the point you want to go, and the Timeline Slider will jump to that frame.

Below the Frames Track are some information fields and controls that you can use to control various aspects of the Timeline and the animation in general. From left to right, they are as follows:

Total: This field displays the TOTAL number of frames in your complete animation. When you create a new empty scene, the Timeline defaults to 31 frames total (just over a second at 30 Frames Per Second). You add more frames to an animation by simply typing in a new larger number in this field and pressing RETURN. At the present time, adding new frames always appends them to the END of the animation. There is currently no way (that I know of) to INSERT frames at the beginning or into the middle of the Timeline.

Range: These fields display the start frame (left field) and end frame (right field) of the range currently displayed in the Frames Track. Please note: Frames are numbered starting at ZERO. So for a Timeline that runs from 0 to 30, you have 31 frames total. You can adjust the range of frames by simply typing in new values into the appropriate fields and pressing RETURN. You can also change the range by clicking and dragging on the black triangles in the Playrange Track. The left triangle sets the start frame of the range, and the right triangle sets the end frame of the range.

Current: This field just tells you which frame number the Timeline Slider is currently on. You can jump to any frame you want by typing in that frame number and pressing RETURN.

Time Code Display: This field displays the current time code in hours:minutes:seconds:frames. You can not directly edit this field; it just tells you what the current frame's time code is at the current frame rate.

FPS: This field displays the animation's current Frames Per Second (FPS). That is, how many frames are played back per second. North American Standard television signals are played at 29.97 FPS. Many animation programs (including DAZ Studio) just use 30 FPS as a close enough approximation. Most European broadcast standards (such as PAL and SECAM) use 25 FPS. Films traditionally use 24 FPS. A lot of web video (for bandwidth reasons) use 15 FPS, which is widely considered to be the minimum for reasonably smooth video. Some applications, such as Flash, do use lower settings (10 or 12 FPS) but great care must be taken to prevent jerky motions. DAZ Studio defaults to 30 FPS, but you may enter whatever number is appropriate for you final output. Bear in mind that this setting applies to the entire animation and will not vary even if you add new frames. If you start the animation at one setting (say 30 fps) and later change your mind and alter the setting (say to 15 fps) DAZ Studio will do it's best to modify the movements of your scene and objects to match. However, I would advise against changing the setting once you start. Decide at the outset what FPS you wish to use and then stick with it. If you end up changing your output media (say from web video to broadcast video) then use a proper video editing package to do so. A safe bet is to always work with a higher setting than you need and then down sample later as desired.

Loop Button: This button toggles looping on and off for the animation. If looping is on, the animation playback will jump back to the first frame of the range and start over again when the end of the range is reached. If looping is off, the animation will stop at the last frame and the Timeline Slider will jump to (and stop at) the first frame of the range.

Play Button: This button previews the animation in its current state (subject to the Loop Button's setting and the range set in the Playrange Track). The animation is previewed in the View Port (see the DAZ Studio manual for an explanation of the View Port). How smoothly the animation is played is dependent on many factors, such as the complexity of the scene, the complexity of the animation, how fast your video card is, how much memory your computer has, and how fast your computer is. Obviously, a slow computer with little memory and an old, slow video card will not display as fast as a new fast computer with the best video card money can buy. However, the playback seen in the View Port is just a preview. No matter how jerky and otherwise unacceptable the preview may seem, only a final render to a video file will truly show you what you have. The preview should be used as a guide and a “spot check” to make sure your animation is on track (pun intended).

Create Keyframe Button: This button creates a keyframe at the current frame. A keyframe is a point at which some important motion or other change takes place. Keyframes are the basis of animation, and proper use of keyframes can make or break an animation project. Keyframes are usually set at the beginning and the end of a motion, and DAZ Studio automatically fills in the changes in between. More on this later.

Delete Keyframe Button: This button deletes a keyframe. Note: It does NOT delete the frame itself, just the keyframe setting on the frame.

Playback Control Buttons: This cluster of buttons behaves much like a VCR to control the playback of the animation preview. In order from left to right, the buttons let you jump to the beginning of the Playrange, jump to the previous keyframe, jump to the previous frame, play/pause the animation, jump to the next frame, jump to the next keyframe, and jump to the end of the Playrange. All of these actions are relative to where the Timeline Slider is located (i.e. pressing the Play Button when the Slider is on frame 15 will start playback at frame 15).

Step 2 - SIMPLE KEYFRAME ANIMATION

300-03af.jpg

Now that you know the parts of the Timeline and what they do, let's go ahead and play with keyframe animation. Start with a new, blank scene and bring in the Dragonfly (go to the Content tab, select the DAZStudio folder, select the Animals folder, and double-click on the Darter DragonFly). The Dragonfly will default to the bottom of the View Port. Go ahead and position the Dragonfly somewhere in the upper left of the View Port, as shown above. Now open the Timeline and place the Timeline Slider on frame 15. Any changes you make to the scene now will be recorded on frame 15, and DAZ Studio will automatically fill in frames 0 through 14 with the appropriate motion. For example, position the Dragonfly at the bottom middle of the View Port. Then click on the Create Keyframe button. This will create a keyframe on the current frame. Now, click and slowly drag the Timeline Slider back to frame 0. You will see the Dragonfly smoothly return back to its starting point in frame 0. Now click the Play Button and watch the Dragonfly and the Timeline carefully. You will see the Dragonfly move from the upper left to the bottom middle over the course of frames 0 through 15. From frames 16 through 30, the Dragonfly will stay put at the bottom of the View Port (because you haven't yet specified any motions for it during those frames). When the Timeline Slider loops back to frame 0 at the end of the animation, the Dragonfly will jump back to its starting point. Go ahead and stop the animation by clicking on the Play button again.

Now position the Timeline Slider on the last frame (frame 30). Position the Dragonfly at the upper right of the View Port. Now click on the Play button and watch the Dragonfly. It should move in a “V” shape across the View Port repeatedly.

300-03b0.jpg

Stop the animation and place the Timeline Slider on frame 15. Remember that we created a keyframe at this position. Click the Delete Keyframe button to delete that keyframe. Now play the animation and observe the difference. Since you've deleted the keyframe at frame 15, the Dragonfly no longer moves to the bottom of the View Port. Instead, it just proceeds directly from its starting position in frame 0 to its ending position in frame 30 (directly across the View Port).

300-03b1.jpg

This is keyframe animation in a nutshell.

Step 3 - NOTES ABOUT KEYFRAMES

There are two very important properties to keep in mind about keyframes. First, keyframes are not marked or shown in any way in the Timeline. When you performed the steps above you should have noted that there is no visual cue pinpointing the location of keyframes. However, the control buttons DO allow you to jump to the previous keyframe and jump to the next keyframe. Also, it should usually be obvious from watching the animation preview in the View Port where the keyframes are: any frame where there is a major change in motion or other attributes of an object.

Second, keyframes apply to specific OBJECTS in the frame, or sub-parts of objects. In the Dragonfly example, we moved the entire Dragonfly because the entire Dragonfly was selected by default. We could also have selected individual parts of the Dragonfly (such as the wings, for example) and made keyframes of their positions as well. Go back to the Dragonfly as we left it above. At frame 7, frame 15, and frame 22, position and set keyframes on each of the Dragonfly's wings (expand the Darter DragonFly in the Scene tab, select each of its four wings in turn, and adjust the “Bend” parameter by about 10 or -10 units, depending on which side you're on and how you wish the wings to beat). Now preview the animation. The Dragonfly is now moving AND BEATING IT'S WINGS as it flies across the View Port. This is an example of an “Animation Cycle” and is addressed further in another one of my tutorials (Victoria 3 Walk Cycles). If you wish, you could go back to frame 15, select the WHOLE Dragonfly in the scene tab, and move it back to the bottom of the view port. The wings would still continue to beat INDEPENDENTLY of the settings on the rest of the body. Likewise, you could then delete the keyframe on the Dragonfly's body (at frame 15) and the keyframes set on the wings would still be there and unaffected.

As far as I can tell, EVERY object in a scene (including lights and cameras) can be keyframed. This means that not only can your objects be moving through a scene, but the cameras and lights can be moving too.

Step 4 - TAKING THE NEXT STEP: POSES AND THE TIMELINE PART II

300-03b2.jpg

Click on the “Clear the Scene” icon (or select “New” in the File menu) to create a new blank scene. Then go to the Content tab, open the DAZStudio folder, open the Scenes folder, and click on the Faerie Forest folder. Double-click the icon labeled “Faerie Forest DAY” to load that scene. After a few moments, you should see something like the image above. Switch to the Scene tab and make sure “Victoria 3 RR LE” is selected (click once on her name if it is not already selected). Open the Timeline and type 61 into the Total field. This will add 30 new frames to the Timeline (notice that the Playrange Track changes to highlight only frames 0 through 30, and how the Range fields show that as well). In the Frames Track, move the Timeline slider to frame 30. Switch back to the Content tab and find the poses for the Faerie (look in DAZStudio > People > Victoria > Poses > Faerie). Double-click on the pose named “Climbing” to apply it. Now use the Parameters dials (or the Translate Tool) to move the Faerie into the upper left portion of the View Port. You should now have something that looks like this:

300-03b3.jpg

If you scrub the Timeline now by clicking and slowly dragging the Timeline Slider around, you will see the Faerie not only move in space (“translate in space” is the proper nomenclature) but she will also change her body pose as she moves. DAZ Studio is smart enough to shift and adjust every part of her body appropriately from the start pose at frame 0 to the end pose at frame 30. When you applied the pose at frame 30, a keyframe was automatically set for EVERY PART OF HER BODY involved in the pose.

Step 5 - TAKING THE NEXT STEP: POSES AND THE TIMELINE PART II

Let's adjust the Playrange Track to show our entire animation. Either drag the right Playrange marker all the way to the right, or just enter 60 into the right Range field. Either way, you will now be able to access the additional 30 frames of the animation that were added in the step above. Now place the Timeline Slider on frame 60. In the content pane, apply the “Cast Spell 02” pose. Use the parameters dials or the Translate Tool to move the Faerie into the middle left-hand portion of the View Port. You should now have something that looks like this:

300-03b4.jpg

Now preview the animation (notice that since we've selected the entire animation in the Playrange Track, you will see the entire animation from frame 0 to frame 60). Since we now have 61 frames total and the animation is being run at the default 30 FPS, the total animation should be about 2 seconds long. If your machine is not fast enough to preview the animation smoothly, just “scrub” the Timeline by dragging the Timeline Slider along. The resulting animation isn't bad at all, for the amount of effort put into it. Using preset poses helps save a great deal of time, since otherwise you would have to do all the posing yourself. Furthermore, if there's something you don't like about the in-between frames (commonly called the “tween” frames) you can always create new keyframes in the problem spots and adjust the movement or positioning of the various elements of your scene.

Step 6 - RENDERING TO VIDEO

So far, we've just been previewing the animation by watching it in the View Port. Even on faster machines, the animation is unlikely to be smooth. To REALLY see what you have, you must render the animation out to a video file. To do this, bring up the Render Settings dialog by going to the Render menu and selecting “Render Settings…”

300-03b5.jpg

First, choose whatever render settings you wish in the Speed section. I find that on the appropriate hardware, OpenGL hardware renders are both fast and very high quality. For the ultimate quality, use the 3Delight software renderer. Just be aware that the software renderer could take a LONG time to finish, since you are producing 61 WHOLE PICTURES for your video file. Basically, use whatever settings you might normally use for your stills. Refer to the DAZ Studio manual for more information regarding the quality settings and the Advanced tab. In the Style section, I always leave it set to normal (the cartoon setting only works with certain video cards and is used in specialized applications anyway).

Second, in the Dimensions section you can choose the frame size for your video. DAZ Studio defaults to using the View Port size, but by using the drop-down menu you can set other sizes as desired. For the curious, DV video streams (as used by many video editing programs) are typically 720 x 480. However, to maintain proper aspect ratios I often use 720 x 540 and let the video editor do the aspect translation for me.

Third, in the Timeline section check the “Make Movie” radio button. DAZ Studio usually defaults to outputting whatever the Playrange Track is set to. You can override that and directly tell DAZ Studio what range you wish to render. This is useful for rendering only subsets of very long animations. For our purposes, just make sure the whole animation (from 0 to 60) is set.

Fourth, in the “Render To” section select the “File” radio button and then use the button marked ”…” to choose where you want the video file and what you wish to name it.

Click the Accept button and then render the animation like you would any other render (i.e. click on the Render Button or select “Render” from the Render menu or use Ctrl+R/Command-R). Now go get some coffee. Maybe a lot of coffee, depending on how fast your machine is. You may even wish to let it render overnight, if your machine is REALLY slow. DAZ Studio will give you a progress read-out in the status bar at the bottom of the screen. Eventually the render will finish, and what happens next depends on what kind of system you have. On a Windows computer, you will be asked for a Codec setting. Codecs are outside of the scope of this tutorial, but lots of information can be had by Googling around. I typically use the No Compression setting, and use other software for my editing and compression needs. Once that has been set, the file will be compressed (or not) and saved as you specified. On a Mac OS X computer, DAZ Studio defaults to PNG compression automatically. This is a good choice too, as it is a “lossless” codec that retains full quality. You can then use whatever video compressor you wish (I use Quicktime Pro on both platforms with excellent results).

Open up the video file and play it on your favorite video playback tool. If you used the No Compression option in Windows, be aware that the video file could be HUGE. You would be well advised to go ahead and compress it with something like Windows Media Player or Quicktime Pro (say using the MPEG-4 codec or the like) and THEN watch it. The video will play much smoother.

You now know about as much as there is to know about the Timeline. It is a simple tool without many of the features found in more advanced animation tools. The reason is simple: DAZ added this feature very late in development and has been focusing its resources on making sure the rest of the program works correctly. It is widely expected that as DAZ Studio progresses, the Timeline will pick up more features (such as, ahem, visible keyframe markers…) and tools for vastly improved animation. I really look forward to that day. I hope you have enjoyed this tutorial and learned something useful.